Mazda3Club.com  

Go Back   Mazda3Club.com > General Discussion > 2nd Gen Protege
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Calendar Search Today's Posts Mark Forums Read Used CarsVendors TSB & Recalls
Welcome to Mazda3Club.com

2nd Gen Protege General/Maintenance Discussion for 1995-1998 Models Only (BH Chassis)

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old December-2nd-2004, 12:16 PM   #1
pepeno
Registered User
 
Join Date: Dec 2004
Posts: 3
pepeno is on a distinguished road
Question '98 Protege wiper problem

The wipers on my '98 protege quit working yesterday
(during a snowstorm!).

Here is what I have discovered so far:

the wiper motor is fine, I can hear/feel it whirring away
the wiper arms can be moved easily (in unison)

My take on this is that the arms have become
disconnected from the wiper motor some how.
Anyone out there have this problem?
Is it a know issue?
Is it a big job to repair this?
pepeno is offline   Reply With Quote
Old December-3rd-2004, 05:54 PM   #2
turbonium959
Oil Change Enthusiast
 
turbonium959's Avatar
 
Join Date: Apr 2002
Location: Norwood, MA
Posts: 1,587
turbonium959 is on a distinguished road
Send a message via AIM to turbonium959
Have you tried tightening the nut that holds the wiper to the motor shaft? Most times than others, the nut comes loose sometimes, especially when winter comes, and people try to move the wiper blades when they are either frozen to the windshield, or there is a ton of snow on the windshield. Other than that, I would just recommend you to take out the motor and inspect it first had. As far as taking it out, I am not sure how difficult it is, but maybe some one else can help out with that?
turbonium959 is offline   Reply With Quote
Old December-6th-2004, 08:00 AM   #3
pepeno
Registered User
 
Join Date: Dec 2004
Posts: 3
pepeno is on a distinguished road
I fixed this on Sat morning, it was quite simple to do actually.
The shaft is connected to the motor with a plastic pivot
that snaps on to the wipre motor shaft. This is where it broke off
and thus I needed to replace this shaft and pivot.
All is well now.
pepeno is offline   Reply With Quote
Old December-8th-2004, 12:57 PM   #4
murcielago
Registered User
 
murcielago's Avatar
 
Join Date: Feb 2003
Location: Montreal,QC
Posts: 127
murcielago is on a distinguished road
Send a message via ICQ to murcielago Send a message via AIM to murcielago Send a message via Yahoo to murcielago
same thing

Yeah, i was actually gonna tell u to check that.
I broke mine last year, that little pivot is so cheap that you really have to be careful with it.
I left some snow on my windshield then just put on the wipers and snap, they stopped working.

How much did u pay for the linkage part?
murcielago is offline   Reply With Quote
Old December-8th-2004, 01:58 PM   #5
pepeno
Registered User
 
Join Date: Dec 2004
Posts: 3
pepeno is on a distinguished road
The part cost me $33 Canadian which isn't so bad if it lasts
5 - 6 years.
pepeno is offline   Reply With Quote
Old December-8th-2004, 02:40 PM   #6
murcielago
Registered User
 
murcielago's Avatar
 
Join Date: Feb 2003
Location: Montreal,QC
Posts: 127
murcielago is on a distinguished road
Send a message via ICQ to murcielago Send a message via AIM to murcielago Send a message via Yahoo to murcielago
yeah, not bad! i know that when i broke mine it was freezing cold and i was too lazy to check it out myself, so i brought it to a mechanic and i ended up payin like 100 bucks cdn for them to change it.. But i will know for next time.. (hopefully there won't be one though)
murcielago is offline   Reply With Quote
Old December-8th-2004, 02:40 PM
Mazda3Club
Mazda3




Paid Advertisement
 
 
 
Reply

Tags
problem, protege, wiper


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine problem w. 96 Protege lpd213 2nd gen Engine/Drivetrain 2 August-11th-2004 04:11 PM
1996 Protege Transmission Problem: Is Car Worth Fixing? kc27 2nd gen Engine/Drivetrain 1 August-1st-2004 09:57 AM
Protege questions /spec-v rocketman 3rd Gen Protege/MazdaSpeed/P5/MP3 5 December-6th-2002 08:44 PM




All times are GMT -5. The time now is 11:36 AM.


All content Copyright © 2012 by Internet Brands, Inc.