Mazda3Club.com  

Go Back   Mazda3Club.com > General Discussion > Mazda3/Mazdaspeed3
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Calendar Search Today's Posts Mark Forums Read Used CarsVendors TSB & Recalls
Welcome to Mazda3Club.com

Mazda3/Mazdaspeed3 General/Maintenance Discussion of the Mazda3 and MazdaSpeed3

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old June-27th-2009, 04:58 PM   #1
nejuza
Registered User
 
Join Date: Jun 2009
Location: Baltmiore
Posts: 8
nejuza is an unknown quantity at this point
Check Engine Light P0455=3rd time! HELP!

I've brought my '05 3s hatchback into the shop 3 times now for the mysterious Check Engine Light P0455.

First time...they changed the gas cap for a new one (per the TSB). The light was off for a little while.
Second time....they changed the Purge Solenoid Valve with Hose (also per the TSB) The light was off for a little while.
Third time...they said that they were perplexed even after doing a Fuel Evap. Smoke Test....they recommended taking to the Mazda dealer for "...for a possible leak detection". They stated that it might be one of two other issues...but beyond their expertise and capabilites. They gave me a bunch of paperwork to take to Mazda. The light was off for a little while...but came on again today! Ggrrr....I just want to undertand what is going on.

Has anyone had any experience with this situation? Furthermore, why would Goodyear recommend this for the dealer to handle?...is it really that complex that only Mazda could fix it?

Thanks for any input or advice.
nejuza is offline   Reply With Quote
Old July-3rd-2009, 03:44 PM   #2
nejuza
Registered User
 
Join Date: Jun 2009
Location: Baltmiore
Posts: 8
nejuza is an unknown quantity at this point
Update to CEL P0455: "tap and clear" solution!

I followed some advice that User: rsx type s - had advised in a 08/01/07 post regarding the commonplace purge solenoid valve defect for the Mazda3; he advised to merely tap on the solenoid valve, which is typically stuck open. It worked! I cleared the CEL light (by disconnecting the negative terminal on the battery, holding the brake down for 10 seconds, reconnecting the negative terminal = CEL gone, and memory cleared). This lasted for nearly 200 miles, then the CEL came on again; I strongly suspect the valve was stuck open ~ yet again. I brought it into the shop and indeed, that was once again the problem. I guess there is no "permanent" fix....if anyone knows of any, PLEASE let me know. The PSV has already been replaced twice! I seriously doubt I am going to spend another dollar on this particular issue. I'm afraid I'm just gonna have to get used to "tapping and clearing".

~Hope this helps others with this similar CEL issue....what a pain!...other than that, I absolutley love my M3s!

_____________________________________________

Quote:
Originally Posted by nejuza View Post
I've brought my '05 3s hatchback into the shop 3 times now for the mysterious Check Engine Light P0455.

First time...they changed the gas cap for a new one (per the TSB). The light was off for a little while.
Second time....they changed the Purge Solenoid Valve with Hose (also per the TSB) The light was off for a little while.
Third time...they said that they were perplexed even after doing a Fuel Evap. Smoke Test....they recommended taking to the Mazda dealer for "...for a possible leak detection". They stated that it might be one of two other issues...but beyond their expertise and capabilites. They gave me a bunch of paperwork to take to Mazda. The light was off for a little while...but came on again today! Ggrrr....I just want to undertand what is going on.

Has anyone had any experience with this situation? Furthermore, why would Goodyear recommend this for the dealer to handle?...is it really that complex that only Mazda could fix it?

Thanks for any input or advice.
nejuza is offline   Reply With Quote
Old July-11th-2009, 12:18 PM   #3
nejuza
Registered User
 
Join Date: Jun 2009
Location: Baltmiore
Posts: 8
nejuza is an unknown quantity at this point
Update #2 to CEL P0455: "tap and clear" solution!

223 odometer miles later, the CEL came on again = P0455 of course! (brought it in).
Solution...another Tap and Clear....should be good for another 200+ miles; 'til the next update...good luck to other out there with this same problem!
nejuza is offline   Reply With Quote
Old July-29th-2009, 07:07 PM   #4
eceric01
Registered User
 
Join Date: Jul 2009
Posts: 1
eceric01 is an unknown quantity at this point
I just got my car back from a Mazda dealer because of a CEL issue with the same code and I stumbled on this site googling the P0455 code. I'm a little out of place here bec I have a Mazda MPV van but I just want to share what the mechanic found out. Here is what his exact report states "Broken Wires at purge solenoid, hooked up scan tool and retrieved code P0455. Gross leak or no flow detected, inspected evap system and found wires to be pulled out at purge solenoid". I'm still green about cars and motors that's why i ended up paying almost C$200 for the repair.

This is the 2nd time that the CEL is caused by the same problem. The mechanic told me that the connector was broken on a different place than the last time. Both CEL instance were provoked after cranking the A/C to high.

Hope this help some

Cheers

Last edited by eceric01; July-29th-2009 at 07:12 PM.
eceric01 is offline   Reply With Quote
Old July-30th-2009, 06:18 PM   #5
nejuza
Registered User
 
Join Date: Jun 2009
Location: Baltmiore
Posts: 8
nejuza is an unknown quantity at this point
Update #3 to CEL P0455: "tap and clear" solution

1,438 odometer miles later, the CEL came on again. Wow, I'm amazed (and quite pleased)that it went that many miles...but, alas...brought it in and the shop said is was a P0455 of course! So I did another "Tap and Clear"....let's see if my [mostly] trusty 3s hatch can go 1,500+ miles without another CEL P0455!
nejuza is offline   Reply With Quote
Old August-2nd-2009, 10:09 AM   #6
mazurfer
Registered User
 
mazurfer's Avatar
 
Join Date: Jul 2009
Location: Florida
Posts: 48
mazurfer is an unknown quantity at this point
Just for grins.............when you are tightening the gas cap, do you let it click at least 5 times? This is a common thing with the RX8's as well, but making sure it clicks numerous times seems to help. Maybe someone else is putting gas in it on occasion and not clicking it? Just a guess.............in the RX8's it also sometimes takes a new cap, and on occasion even a new filler neck!
mazurfer is offline   Reply With Quote
Old August-16th-2009, 10:15 AM   #7
djs2571
Registered User
 
Join Date: Mar 2007
Location: Churchville,ny
Posts: 901
djs2571 is on a distinguished road
Send a message via AIM to djs2571 Send a message via Yahoo to djs2571
DTC P0455 = evaporative emissions leak (gross leak) & P0456 is a small leak - you knew that one.

Monitored when:
ignition is off
intake temp is 5-35C (40-95F)
battery is above 11V
atmospheric pressure is 72.2KPA or greater (542mmHg, 21.3inHg)
Fuel tank is between 15 and 85%

This sets the light if it's been seen two consecutive drive cycles, or if it has a pending code set (meaning you weren't in the proper conditions in the last cycle - note above).

Causes per the workshop manual:
purge solenoid valve
evap system leak detection pump
loose / defective filler cap
charcoal canister
fuel tank
evap hose

any leaks in the above pieces will cause a failure, since the system can't hold pressure. I would assume that a fuel leak or leaking fuel injectors could do the same thing as well.

The test mazda can do - or other shops with the tools, is sniff for unburned hydrocarbons, aka fuel sniffer. This would point out the general location of the leak. If nothing is found i'd assume something like the leak detection pump - though i'm not sure of it's exact use in the system.
__________________
Dave '07 M3 GT, manual, - black
Adders: backup sensors, current limited hi-beams (for long life), Fog light on with running lights (t=44332 PAGE2), low beam aiming switch adjustment (t=47722), dash squeak reduction, badges removed, door bumpers removed, auto up/down windows, under seat subwoofer, True hidden hitch (t=53213), rear camber fix (t=53425)
Info / help: outside running lights only as DRL (t=54453)
link example http://www.mazda3club.com/showthread.php?t=54453
djs2571 is offline   Reply With Quote
Old August-16th-2009, 11:19 AM   #8
techniciana
Registered User
 
Join Date: Jul 2008
Location: ft.lauderdale
Posts: 16
techniciana is an unknown quantity at this point
the dealer should have been able to locate the leak with the smoke method.humm.did you run anything over just before the c.e.l. came on.could be a leaking kink in your evap lines running from your gas tank to purge solenoid,bad filler neck on your fuel tank.do you smell any gasoline fumes at all??
techniciana is offline   Reply With Quote
Old November-29th-2009, 10:29 AM   #9
nejuza
Registered User
 
Join Date: Jun 2009
Location: Baltmiore
Posts: 8
nejuza is an unknown quantity at this point
Update to CEL P0455 problem:

Thank you to eceric01, mazurfer, djs2571, and techniciana for your posts on this P0455 issue.

I started smelling gas fumes about a month ago and was getting concerned this was releated to the P0455 CEL...I was also getting tired of my previous "tap and clear" band-aid of a solution. So I brought it to a garage that I totally found at random on the internet but which received many glowing reviews about their quality of service...I figured they'd still be less $$$ than the dealer but can't be worse than Goodyear's line that they gave me stating that couldn't find or fix the problem...."beyond their expertise and capabilities"...even after they did the evap smoke test. In Baltimore, MD there is this shop called "A1-Auto Three Brothers Car Repair" (http://www.a1autothreebroscarrepair.com/) These guys were very professional and explained that though they were not a giant national chain or certainly did not have the prolific database of pinpoint trouble shooting that comes with mass volume at a dealership, that they would diagnose and diligently work on my car until they found the problem. I respected their neutrality and the fact that they did not try to "push" their services upon me, I had reservations going with a total unknown garage, but I went with my instincts and it PAID OFF BIG TIME. I was floored when they told me they did another smoke evap test (just like Goodyear) but was able to discern a very slight leakage eminating from the gas tank seal. It was slightly deteriorated and was causing the CEL to trip on from not being able to hold pressurization. They replaced it in a timely manner and at a fair cost...and 1500+ miles later...NO MORE CEL P0455! :-) I believe Goodyear has just lost a life long customer.

To all others out there having an annoying CEL P0455...follow the steps as recommended (gas cap, etc.) but note that it could be a slightly worn gas seal like mine.

Last edited by nejuza; November-29th-2009 at 10:35 AM.
nejuza is offline   Reply With Quote
Old November-30th-2009, 11:27 AM   #10
djs2571
Registered User
 
Join Date: Mar 2007
Location: Churchville,ny
Posts: 901
djs2571 is on a distinguished road
Send a message via AIM to djs2571 Send a message via Yahoo to djs2571
Glad to see you got it fixed, and thanks for updating us on the location of the problem. I'm suprised that a leak detector at the first shop wouldn't have caught the leak goodyear found.
__________________
Dave '07 M3 GT, manual, - black
Adders: backup sensors, current limited hi-beams (for long life), Fog light on with running lights (t=44332 PAGE2), low beam aiming switch adjustment (t=47722), dash squeak reduction, badges removed, door bumpers removed, auto up/down windows, under seat subwoofer, True hidden hitch (t=53213), rear camber fix (t=53425)
Info / help: outside running lights only as DRL (t=54453)
link example http://www.mazda3club.com/showthread.php?t=54453
djs2571 is offline   Reply With Quote
Old November-30th-2009, 11:27 AM
Mazda3Club
Mazda3




Paid Advertisement
 
 
 
Reply

Tags
08, 2006, 2007, cap, check, code, engine, light, mazda, p0455, po455, smoke, solenoid, test, warning


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Mazda 3 5 Door: AT Warning Light on: Check Engine Light on David2006Mazda3 Mazda3/Mazdaspeed3 15 August-25th-2012 09:49 AM
check engine light and the battery light patel0516 Mazda3/Mazdaspeed3 10 May-23rd-2007 07:27 PM
Check Engine Light 4th time. P5s_LetsRoll 3rd gen Engine/Drivetrain 1 April-19th-2004 08:50 PM
Battery Light, Check Engine Light, Came on with new intake??? What Do I do?? hotprotege2002 3rd gen Engine/Drivetrain 40 April-10th-2003 04:50 PM
Anyone know how to check the code for the check engine light? EXavier 2nd gen Engine/Drivetrain 8 July-31st-2002 04:31 PM




All times are GMT -5. The time now is 01:54 PM.


All content Copyright © 2012 by Internet Brands, Inc.