Engine hesitation during acceleration - Mazda3Club.com : The Original Mazda3 Forum
Mazda3Club.com : The Original Mazda3 Forum  


Mazda3/Mazdaspeed3 Engine/Drivetrain Modification Discussions for the Mazda3 and MazdaSpeed3

Reply
 
 
 
Thread Tools Search this Thread
Old May-12th-2018, 07:37 PM   #1  
Registered User
Thread Starter
 
Join Date: May 2018
Posts: 1
Spencer Graffunder is an unknown quantity at this point
Engine hesitation during acceleration

Hey all,

I have a 2007 Mazda3 i 2.0L which has a really annoying problem. I have a video showing it here.

It hesitates whenever I accelerate, no matter what gear, and pretty much regardless of the engine speed. It causes my gas mileage to go to around 20-25 MPG when it was 30-33 before. Of course it makes the car accelerate much slower so my 0-60 is something around 15-20 seconds instead of 9-10 like it should be.

When it started:
When I bought the car in August of 2017, it would do the same thing, but only when around 3300-3500 RPM, and I only noticed it in 3rd gear. Sometime in November, it was much worse, about as bad as it is now. It hasn't changed since then.

Things I've tried:
- Replaced downstream O2 sensor
- Replaced spark plugs with Denso TT Plats
- Replaced MAF sensor
- Fuel injector cleaner

Today when I replaced the spark plugs, I noticed quite a bit of oil on the spark plugs, above the threads, so tomorrow I'm going to replace the valve cover gasket. Since replacing the plugs, it doesn't hesitate all the time, only about 1/2-3/4 the time. I don't think the oil is the main cause of the problem, so I'm asking here still.

Last edited by Spencer Graffunder; May-12th-2018 at 07:41 PM.
Spencer Graffunder is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
engine hesitation after Injen install trex2500 3rd gen Engine/Drivetrain 7 May-16th-2004 05:07 PM
Squeek in from engine during third gear pull on a 01 ES jaymaz20 3rd Gen Protege/MazdaSpeed/P5/MP3 0 December-6th-2002 02:43 PM
Engine Vibration , hesitation at 60 mph laf1greg 1st Gen Protege/323/GLC 3 October-20th-2002 06:13 PM
engine stumbles on acceleration 96/1.5 pacho 2nd gen Engine/Drivetrain 2 October-13th-2002 05:23 AM
Flat spots on acceleration - engine cold josh9465 2nd gen Engine/Drivetrain 1 July-6th-2002 02:23 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:19 PM.


All content Copyright © 2017 by Internet Brands, Inc.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.