Mazda3Club.com  

Go Back   Mazda3Club.com > General Discussion > Mazda Service Info
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Members Calendar Search Today's Posts Mark Forums Read Used CarsVendor Directory
Welcome to Mazda3Club.com

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old February-1st-2011, 08:27 PM   #1
bradford027
Registered User
 
Join Date: Feb 2011
Posts: 5
bradford027 is an unknown quantity at this point
Surging at idle

I have an 05 mazda3 w/ AT and a 2.0l. I bought it w/ 20,000 miles and now its at about 58,000. The engine pulses or surges at idle in drive, like at a stop light. If I put it in neutral or park it smoothes out immediatly. Its done this for the majority of the time Ive owned it, although it seems to be getting a little worse and more frequent this winter. I always try to work on vehicles myself before resorting to a shop. Any tips on what to check or look for would be greatly appreciated. I searched the forum and couldnt find my problem . Thanks.
bradford027 is offline   Reply With Quote
Old February-1st-2011, 08:33 PM   #2
bradford027
Registered User
 
Join Date: Feb 2011
Posts: 5
bradford027 is an unknown quantity at this point
Also...theres no check engine light now or ever and it doesnt seem to make a difference if the AC is on or off.
bradford027 is offline   Reply With Quote
Old February-2nd-2011, 11:13 AM   #3
djs2571
Registered User
 
Join Date: Mar 2007
Location: Churchville,ny
Posts: 901
djs2571 is on a distinguished road
Send a message via AIM to djs2571 Send a message via Yahoo to djs2571
could have a vacuum leak / loose intake causing a leak. Or maybe the throttle plate needs cleaning, since this is a fly by wire, if its sticking a little it could be surging to compensate under no load.
A diagnostic tool may help, looking at realtime data to see if some signal correlates to the surging.
__________________
Dave '07 M3 GT, manual, - black
Adders: backup sensors, current limited hi-beams (for long life), Fog light on with running lights (t=44332 PAGE2), low beam aiming switch adjustment (t=47722), dash squeak reduction, badges removed, door bumpers removed, auto up/down windows, under seat subwoofer, True hidden hitch (t=53213), rear camber fix (t=53425)
Info / help: outside running lights only as DRL (t=54453)
link example http://www.mazda3club.com/showthread.php?t=54453

Last edited by djs2571; February-2nd-2011 at 11:14 AM. Reason: wording
djs2571 is offline   Reply With Quote
Old February-2nd-2011, 05:31 PM   #4
bradford027
Registered User
 
Join Date: Feb 2011
Posts: 5
bradford027 is an unknown quantity at this point
I cleaned the TB and while I was at it I cleaned the MAF sensor. I couldn't find any vac leaks. I took it for a couple of 5 or 10 miles drives and it seems to have made a big difference. It made a noticable difference in power and no more surging ...yet. time will tell I guess. If I turn on the AC it idles up and down as the compressor kicks on but now it does so smoothly. I'm pretty sure that's normal though. One last question. Exactly where is the IAC and the PCV ? I was going to check those and wasn't exactly sure. Thanks.
bradford027 is offline   Reply With Quote
Old February-3rd-2011, 05:32 AM   #5
djs2571
Registered User
 
Join Date: Mar 2007
Location: Churchville,ny
Posts: 901
djs2571 is on a distinguished road
Send a message via AIM to djs2571 Send a message via Yahoo to djs2571
Mine's a 2007, but I notice zero difference in idle when the AC cycles. Though when driving I can feel a slight power difference when the AC cycles.
Idle Air Control - it's all electronic, no manual screws or anything, idle speed is not adjustable. Spec for the idle is 600-800 depending on the engine load, so it looks ok for it to cycle a bit.
The PCV (from the manual) looks like it's on the front side of the engine, but the pic isn't clear.
__________________
Dave '07 M3 GT, manual, - black
Adders: backup sensors, current limited hi-beams (for long life), Fog light on with running lights (t=44332 PAGE2), low beam aiming switch adjustment (t=47722), dash squeak reduction, badges removed, door bumpers removed, auto up/down windows, under seat subwoofer, True hidden hitch (t=53213), rear camber fix (t=53425)
Info / help: outside running lights only as DRL (t=54453)
link example http://www.mazda3club.com/showthread.php?t=54453
djs2571 is offline   Reply With Quote
Old February-3rd-2011, 12:22 PM   #6
mattconti
Registered User
 
Join Date: Jan 2011
Location: Montreal, Canada
Posts: 3
mattconti is an unknown quantity at this point
I have the same model as you and I've been having a similar problem on and off for the last 5 years, although the engine will at times fluctuate and dip so low on the rpm gauge that the car will stall when i come to a stop sign. After taking it in for a diagnostic test I was told that my EGR valve was malfunctioning and it either needed to be replaced (350$ was the estimate) or cleaned. I haven't taken action yet since it only occurs once in a blue moon now but maybe the valve could be dirty like mine. I've been told it is a common problem on 2.0l Mazda engines.
mattconti is offline   Reply With Quote
Old February-3rd-2011, 03:53 PM   #7
bradford027
Registered User
 
Join Date: Feb 2011
Posts: 5
bradford027 is an unknown quantity at this point
Thanks for the tip. Where exactly is the EGR valve?
bradford027 is offline   Reply With Quote
Old February-3rd-2011, 04:07 PM   #8
mattconti
Registered User
 
Join Date: Jan 2011
Location: Montreal, Canada
Posts: 3
mattconti is an unknown quantity at this point
Facing the engine compartment, its on the right hand side of the engine, easily accessible by removing the air filter box. There are plenty of photos online of its exact position and all you need is carbon buildup cleaner to clean it. Since your car isn't stalling like mine, I doubt you need to replace it if it was the problem.
mattconti is offline   Reply With Quote
Old August-7th-2012, 05:18 PM   #9
lFinck
Registered User
 
Join Date: Aug 2012
Posts: 1
lFinck is an unknown quantity at this point
Unhappy surging & breaks hardly working

i have a 04 mazda 3 with 126,000 miles on it and a month ago it was surging a little while i was driving, and i didnt happen again until yesterday so i didnt think it was a big deal. but yesterday i was driving on the freeway when it happened, not driving 25-30mph like i was the first time. it was surging to where it made me speed up & then my breaks were not working very well at all, i almost rear ended a a car because it took so long to stop. then also when i finally came to a stop and put my car in park my car was still revving up by its self, which i different bc most have said the problem gets fixed when they put their car in park or neutral. also no one has mentioned anything about their breaks practically going out, but mine did. then once i turned the car off and then back on again everything was back to normal, breaks worked and surging stopped. what is different about my problem? or is it the same? anyone have any clue?
lFinck is offline   Reply With Quote
Old August-30th-2012, 04:42 AM   #10
asharca
Registered User
 
Join Date: Aug 2012
Posts: 4
asharca is an unknown quantity at this point
A vacuum leak would generally cause a high idle. although you could have a vacuum leak , I don't believe that is what is causing the rough idle and the fact that your car wants to shut off at traffic lights. check/change the idle air control valve and for good measure , check your vacuum hoses.
__________________
asharca is offline   Reply With Quote
Old August-30th-2012, 04:42 AM
Mazda3Club
Mazda3




Paid Advertisement
 
 
 
Reply

Tags
07, 98, engine, gear, madza, mazda, mazda3, park, protege, rpm, stall, surge, surgeing, surges, surging


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
idle Greigers-Gen 1 1st Gen Protege/323/GLC 7 March-20th-2004 10:07 AM
Very low idle naira 2nd gen Engine/Drivetrain 4 September-17th-2003 09:10 AM
02 ES surging Sias 3rd Gen Protege/MazdaSpeed/P5/MP3 0 May-1st-2003 11:19 AM
Engine surging trvlngcow 2nd gen Engine/Drivetrain 4 January-31st-2003 08:23 PM
Idle Hong Kong Fever 3rd gen Engine/Drivetrain 8 January-31st-2003 12:40 AM




All times are GMT -5. The time now is 12:54 AM.


All content Copyright © 2012 by Internet Brands, Inc.