'98 Protege wiper problem - Mazda3Club.com : The Original Mazda3 Forum
Mazda3Club.com : The Original Mazda3 Forum  


2nd Gen Protege General/Maintenance Discussion for 1995-1998 Models Only (BH Chassis)

Reply
 
 
 
Thread Tools Search this Thread
Old December-2nd-2004, 01:16 PM   #1
Registered User
Thread Starter
 
Join Date: Dec 2004
Posts: 3
pepeno is on a distinguished road
Question '98 Protege wiper problem

The wipers on my '98 protege quit working yesterday
(during a snowstorm!).

Here is what I have discovered so far:

the wiper motor is fine, I can hear/feel it whirring away
the wiper arms can be moved easily (in unison)

My take on this is that the arms have become
disconnected from the wiper motor some how.
Anyone out there have this problem?
Is it a know issue?
Is it a big job to repair this?
pepeno is offline   Reply With Quote
Old December-3rd-2004, 06:54 PM   #2
Oil Change Enthusiast
 
turbonium959's Avatar
 
Join Date: Apr 2002
Location: Norwood, MA
Posts: 1,587
turbonium959 is on a distinguished road
Have you tried tightening the nut that holds the wiper to the motor shaft? Most times than others, the nut comes loose sometimes, especially when winter comes, and people try to move the wiper blades when they are either frozen to the windshield, or there is a ton of snow on the windshield. Other than that, I would just recommend you to take out the motor and inspect it first had. As far as taking it out, I am not sure how difficult it is, but maybe some one else can help out with that?
turbonium959 is offline   Reply With Quote
Old December-6th-2004, 09:00 AM   #3
Registered User
Thread Starter
 
Join Date: Dec 2004
Posts: 3
pepeno is on a distinguished road
I fixed this on Sat morning, it was quite simple to do actually.
The shaft is connected to the motor with a plastic pivot
that snaps on to the wipre motor shaft. This is where it broke off
and thus I needed to replace this shaft and pivot.
All is well now.
pepeno is offline   Reply With Quote
Old December-8th-2004, 01:57 PM   #4
Registered User
 
murcielago's Avatar
 
Join Date: Feb 2003
Location: Montreal,QC
Posts: 127
murcielago is on a distinguished road
same thing

Yeah, i was actually gonna tell u to check that.
I broke mine last year, that little pivot is so cheap that you really have to be careful with it.
I left some snow on my windshield then just put on the wipers and snap, they stopped working.

How much did u pay for the linkage part?
murcielago is offline   Reply With Quote
Old December-8th-2004, 02:58 PM   #5
Registered User
Thread Starter
 
Join Date: Dec 2004
Posts: 3
pepeno is on a distinguished road
The part cost me $33 Canadian which isn't so bad if it lasts
5 - 6 years.
pepeno is offline   Reply With Quote
Old December-8th-2004, 03:40 PM   #6
Registered User
 
murcielago's Avatar
 
Join Date: Feb 2003
Location: Montreal,QC
Posts: 127
murcielago is on a distinguished road
yeah, not bad! i know that when i broke mine it was freezing cold and i was too lazy to check it out myself, so i brought it to a mechanic and i ended up payin like 100 bucks cdn for them to change it.. But i will know for next time.. (hopefully there won't be one though)
murcielago is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Wiper Problem Finprof 1st Gen Protege/323/GLC 1 January-27th-2005 11:18 AM
Will 205/55-16 be a problem on a Protege 5? Undepelo Wheel/Tires 3 December-26th-2004 08:54 PM
Problem with 2nd Gen 95 Protege alexjohnson16 Exterior/Interior/Audio 6 August-19th-2003 06:28 PM
Wiper size for P5 iroc326 3rd Gen Protege/MazdaSpeed/P5/MP3 17 July-11th-2003 09:25 PM
Problem With Protege 00 ES 1.8 protoge'00 3rd Gen Protege/MazdaSpeed/P5/MP3 13 June-2nd-2003 06:29 PM


Tags
problem, protege, wiper


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 11:45 AM.


All content Copyright © 2012 by Internet Brands, Inc.